Back to overview
Downtime

Major service outage.

Apr 23, 2026 at 3:15pm UTC
Affected services
Dashboard
API
Analysis Runs
Autofix Runs
Transformer Runs
Webhooks
Autofix AI

Resolved
Apr 23, 2026 at 6:30pm UTC

All services are operating nominally. We are continuing to monitor the systems for any anomalies.

Updated
Apr 23, 2026 at 4:00pm UTC

Services have been partially restored. Most functionality is available again, but some analysis requests might be stuck. We recommend closing and re-opening your PRs if they have been stuck for a long time.

Created
Apr 23, 2026 at 3:15pm UTC

We are experiencing a major outage affecting DeepSource. All DeepSource services are currently unavailable or severely degraded. We are aware of the issue, and our engineering team is actively working to restore service.