Back to overview
Downtime

DeepSource Analysis Runs Temporarily Unavailable

Jun 12 at 06:20pm UTC
Affected services
Analysis Runs
Autofix Runs
Transformer Runs

Resolved
Jun 12 at 08:15pm UTC

The earlier disruption caused by a global outage with our upstream provider (Google Cloud Storage) has now been resolved. All affected services, including Code and SCA Analysis, Transformer, Legacy Autofix, and Test Coverage, are back online and functioning as expected.

We've automatically retried all Code Analysis and Legacy Autofix runs that failed or timed out during the incident window. However, for other features:

Transformer and SCA Analysis: Please trigger a retry by either closing and reopening the pull request or pushing a new commit to the same branch.

Test Coverage: If affected, re-run the CI workflow responsible for uploading coverage data.

We appreciate your patience and understanding during the incident. If you continue to experience any issues, please reach out to our support team.

Created
Jun 12 at 06:20pm UTC

Due to a global outage with our upstream service provider (GCP's Google Cloud Storage), several features including Code and SCA Analysis, Transformer, Legacy Autofix, and Test Coverage are currently unavailable. We are actively monitoring the situation and working on a fix.